Här finns tips och guider för Ubuntu.

lördag 24 februari 2007

Installera Java

Om du besöker Javas testsida och möts av nedanstående bild



så är java inte installerat på datorn. Denna guide visar hur man gör för att installera Java och konfigurera det för Swiftfox/Firefox.
Gå till Javas nerladdningssida och klicka på hämta nu. Välj "Linux (självextraherande fil)" och klicka på hämta. Välj spara till disk (Guiden bygger på att du laddat ner filen till ditt Skrivbord).
Skriv sedan in följande i en terminal

sudo mkdir /usr/java/

följt av

cd /usr/java/


Nu när du befinner dig i javakatalogen skriver du in

sudo chmod +x /home/DITTANVÄNDARNAMN/Skrivbord/jre-6u3-linux-i586.bin

Därefter

sudo /home/DITTANVÄNDARNAMN/Skrivbord/./jre-6u3-linux-i586.bin

Nu kommer installationsprogrammet att starta. Tryck enter en massa gånger tills du blir tillfrågad om du accepterar avtalet. Tryck y följt av enter och Java installeras. När detta är klart återstår bara att länka Java till din webbläsare.

Om du använder Firefox skriver du nu in följande i ett terminalfönster

cd /usr/lib/firefox/plugins/

Skriv därefter in

sudo ln -s /usr/java/jre1.6.0_03/plugin/i386/ns7/libjavaplugin_oji.so

Om du använder Swiftfox (och den är installerad i katalogen /opt/) skriver du in följande i ett terminalfönster

cd /opt/swiftfox/plugins/


följt av

sudo ln -s /usr/java/jre1.6.0_03/plugin/i386/ns7/libjavaplugin_oji.so

Starta om din webbläsaren och besök Javas testsida och du möts förhoppningsvis av nedanstående bild.

Andra bloggar om: , ,

21 kommentarer:

notwist sa...

Ingen ide att krångla till det ju.. i pakethanteraren Synaptic kan man söka efter "firefox java", då hittar man paketet j2re1.4-mozilla-plugin. Det fixar biffen. Eller?

Bossieman sa...

Stämmer, dock så är guiden här för en mycket nyare version av Java än den som är i Synaptic.

Björkis sa...

Fantasstisk guide... Satt och slet mitt hår, behövde skapa ett BAnkID, men utan att lyckas, och att instalera java plugin från firefox gick inte... Men sen hitta jag denna guide och det funka med en gång...

TACK!

Gamlao sa...

Tack, äntligen en guide som tom jag förstod

Ragamuffin sa...

Guiden fungerade perfekt när korkade jag till slut insett att jag laddat ner fel program..
Jag valde först den som hetter "rpm.bin".. den första självextraherande jag såg för linux:) Den var tydligen inte till Ubuntu..

Anonym sa...

Klockren instruktion
Tack
Sinkro63

Guraknugen sa...

Jag har fått det att fungera enligt din instruktion i tidigare installationer av Ubuntu, men efter senaste nyinstallationen av Ubuntu Studio 7.10 från Alternate-skivan, lyckades jag inte få det att fungera. I about:plugins ser det ut som att allt gått bra, men Javas testsida fungerar inte.

Efter att ha skrivit sudo apt-get install sun-java6-jre sun-java6-plugin sun-java6-fonts i terminalen så fungerade dock allt som det skulle.

Någon idé om vad som kan ha orsakat mitt misslyckande innan dess?

Anonym sa...

Tackar! Funkade klockrent, nu funkar BankID med Ubuntu 7.10 och FF! TACK!

André sa...

Jag har installerat java enligt guiden ovan. Jag hade java redan innan men det fungerade ändå inte med bank-id. Då fick jag fram följande information på javas testsida:

You are not using the currentversion of JRE available on java.com

vendor: GNU classpatch
Version: 1.4.2


Jag ser också den lilla gubben som åker fram och tillbaka under texten.

Efter installationen så får jag fram exakt samma ruta. Den nya versionen upptäcks inte. Jag har testat att installera om java ett par gånger och försökt ta bort allt jag hittar som har med java att göra i pakethanteraren innan jag testat guiden på nytt. Alltid samma version som upptäckts på testsidan och inget fungerande bank-id. Några förslag?

Bossieman sa...

@André

Sök efter java i synaptic och installera den vägen istället.

André sa...

Det fungerar inte heller tyvärr. Har testat både en och två gånger.

André sa...

Jag har redan testat det. Det verkar inte som jag kan varken avinstallera den versionen jag har, eller få firefox att fatta att jag vill använda den nyinstallerade.

Daniel sa...

Senaste versionen på java.com är 6 updte 6 så länken man skall skapa är ln -s /usr/java/jre1.6.0_06/plugin/i386/ns7/libjavaplugin_oji.so

för just den verstionen av java........

Guiden fungerar utmärkt.

Anonym sa...

Jag har samma problem som andré. Det verkar som om Firefox inte hittar igen uppdateringen. Jag har flera ~/plugins kataloger, så kanske är det så att länkningen ska ske till en annan katalog? Hur vet jag i så fall vilken som skall användas.? Jag använder Firefox 3 Beta 5.

Anonym sa...

Märkligt allting fungerar klockrent men på testsidan vill Firefox v3.3 fortf. ladda ner insticksfiler och vägrar att gå vidare, andra sidor tror att browsen har java disabled fast jag kollat att FireFox har den enabled. Någon lösning?

Jean-Philippe sa...

Jag hade synaptic-versionen installerad och följde denna guide, men javas hemsida säger fortfarande att jag har java 5.0. Någon som kan hjälpa mig?

Kristofer sa...

Efter en update av firefox hade jag fått flera firefox-kataloger under /usr/lib och var tvungen att kopiera filerna från /usr/lib/firefox-3.0/plugins till /usr/lib/firefox-3.0.6/plugins

Sen fungerar det fint

Mattias sa...

För att få det att fungera så var jag tvungen att avinstallera övriga Java versioner via: System > Administration > Synaptic Package Manager

david sa...

Man kan välja vilken version av java som ubuntu ska använda som standard (dvs till plugin m.m.) med hjälp av kommandot update-java-alternatives.

Lista alla olika versioner installerade:
sudo update-java-alternatives -l

Ställa in Java ifrån Sun:
sudo update-java-alternatives -s java-6-sun

Anonym sa...

http://www.blog.highub.com/linux/install-java-on-ubuntu-firefox/

Rickard sa...

jag hittade mina plugins under /usr/share/ubufox/plugins