Här finns tips och guider för Ubuntu.

måndag 12 november 2007

Avant Window Navigator

Jag har tidigare skrivit om AWN och Leopard docken. Den guiden är dock oaktuell och funkar inte. Här är en ny guide för Gutsy Gibbon.



Du behöver Compiz Fusion aktivt för att det här ska fungera samt internetanslutning.

System --> Administration --> Programvarukällor. Klicka på fliken Tredjepartsprogramvara och därefter på Lägg till... och skriv in följande rad

deb http://download.tuxfamily.org/syzygy42 gutsy avant-window-navigator
. Klicka därefter på Lägg till källa. Upprepa sedan proceduren men skriv in följande rad

deb-src http://download.tuxfamily.org/syzygy42 gutsy avant-window-navigator

Öppna nu ett terminalfönster och skriv in följande

wget http://download.tuxfamily.org/syzygy42/reacocard.asc


därefter

sudo apt-key add reacocard.asc

följt av

rm reacocard.asc


Återgå nu till fliken med Tredjepartsprogram och klicka på stäng. Nu kommer Ubuntu fråga dig om du ska Läsa om din repositorylista. Välj det alternativet och vänta tills det hela är klart.
Återgå därefter till terminalen och skriv in

sudo apt-get install avant-window-navigator-bzr awn-core-applets-bzr


Nu är vi klara och du kan börja använda AWN. Du hittar AWN genom Program --> Tillbehör --> Avant Window Navigator. För inställningar och plugins så går du till System --> Inställningar --> Awn manager

20 kommentarer:

Toffer sa...

Hmm, tycker din blogg är skitbra o så... Min favoritblog atm faktiskt =)
Men jag har en fråga, hur får man fram originalinställningarna sen? Vet inte om jag vågar testa köra dessa skript utan att veta hur man får tillbaka originalinställningarna... Är dock väldigt sugen på docken ^^ Tack för en j*vligt bra blogg :D

Anonym sa...

För att få awn att starta automatiskt vid uppstart, öppna inställningar -> sessioner och tryck på lägg till. Skriv något lämpligt, Awn, till exempel och skriv "avant-window-navigator" (utan citattecken) i kommandoraden.

Hälsn. Fonsterbage

Anonym sa...

Hur får man bort den förra versionen av Avant window navigator? Jag har avinstallerat den men den ligger kvar ändå och går att köra.

Victor sa...

Tjena! Har använt AWN sedan du skrev om det i din blogg första gången. Men nu har jag fått problem, docken lägger sig inte längst ned på skärmen utan mitt på. Så vill jag inte ha det, vilken inställning har jag skrivit fel på måntro?

Upplösningen är 1208x1024, om det nu kan hjälpa.

Tackar på förhand!

Bossieman sa...

@victor: Det skulle inte jag heller vilja ha. Testa följande. Gå till din hemmamapp, tryck ctrl + h då ska du se de dolda mapparna. Döp om mappen .screenlets till nåt annat, typ .screenlets2
starta sedan om screenlets, allt ska då vara nollställt. Om detta hjälper så kan du testa att kopiera över grejer till den nya skapade .screenletsmappen och se om du hittar vad det är som krånglar.

Bossieman sa...
Den här kommentaren har tagits bort av skribenten.
Victor sa...

@Bossieman.

Ah, nu missförstod du mig. Tror jag, det är ingen screenlet utan den ''riktiga'' AWN, så det är inte tjafs med screenlets.

Och om det nu är det så finns inte den katalogen i min hemmap alls, dolda filer inräknat då.

Bossieman sa...

@victor - Ja jösses, jag läste helt fel.
.config/awn/ mappen ska det vara.

Anonym sa...

Hej Jag är ny på ubuntu (Gubbe-58) Köpt en ubox Toshiba försöker installera avant-window, har följt din guide, men eftersista steget får jag: E:Kunde inte hitta paketet avant-window-navigator-bzr
Även försökt leta efter paketet via synaptic men resultatet blir samma
E: Kunde inte hitta paketet avant-window-navigator-bzr
Vad gör jag för fel?
Mvh Janne

Bossieman sa...

@Gubbe-58: Du måste ha missat något i guiden. Alla raderna är inte inlagda på rätt sätt. Försök med guiden igen.

Anonym sa...

TACK!! Från Gubbe-58
Gammal man gör så gott han kan,men stavar f-n så illa osv osv.
Lite tålamod var allt som behövdes.
Tack för hjälpen och en SUVERÄN blogg, ovärderlig för en som VILL men kanske inte vågar eller vet hur!

Toffer sa...

Var inne på en annan sida på din blogg samtidigt som jag installerade AWN (som funkar utmärkt, tack för den!). Där skrev du hur man fick båda panelerna i en och jag testade det ^^ Tyvärr råkade jag radera en grej från panelen och jag kan inte se program som körs i bakgrunden längre t.ex pidgin och nya uppdateringar.. Pulade runt lite i inställningarna men hittade inte den inställningen, vet du hur man gör för att få tillbaka det? :S

Bossieman sa...

@Toffer: Högerklicka på panelen --> Lägg till i panelen --> notifieringsyta --> +lägg till.

Toffer sa...

Tackar =)

Robin sa...

Hmm jag får det inte att fungera :S detta är felmeddelandet jag får:

Bygger beroendeträd
Läser tillståndsinformation... Färdig
Några paket kunde inte installeras. Det kan betyda att du har begärt
en omöjlig situation eller, om du använder den instabila utgåvan
att några nödvändiga paket ännu inte har skapats eller flyttats
ut från "Incoming".
Följande information kan vara till hjälp för att lösa situationen:

Följande paket har beroenden som inte kan tillfredsställas:
avant-window-navigator-bzr: Beroende av: libawn-bzr men det kommer inte att installeras
Beroende av: libpango1.0-0 (>= 1.18.3) men 1.18.2-0ubuntu1 kommer att installeras
Beroende av: libawn-bzr (= 0.2.0-bzr151-1) men det kommer inte att installeras
awn-core-applets-bzr: Beroende av: libawn-bzr men det kommer inte att installeras
Beroende av: libpango1.0-0 (>= 1.18.3) men 1.18.2-0ubuntu1 kommer att installeras
Beroende av: libawn-bzr men det kommer inte att installeras
Beroende av: python-libawn-bzr men det kommer inte att installeras
E: Trasiga paket

Bossieman sa...

@Robin
Har du alla repositories iklickade i System--Administration--Programvarukällor?

SVENDUS sa...

Fungerar helt suveränt :-) Tackar och Gott Nytt år Leif

Robin sa...

Hmm vad är det :P?
Jag har alla iklickade i programvarukällor> hämtningsbara filer

/robin

SVENDUS sa...

@ Robin Hmm vad är det :P?
Jag har alla iklickade i programvarukällor> hämtningsbara filer

Vi fick samma felmeddelande först
Du har säkert stängt Tredjepartsprogram
innan du skrev
wget http://download.tuxfamily.org/syzygy42/reacocard.asc
därefter
sudo apt-key add reacocard.asc
följt av
rm reacocard.ascoch
i terminalfönsteret :-)
Du behöver Compiz Fusion aktivt
Svendus

Robin sa...

@svendus nepp det fungerade inte då heller =/ testade en annan guide där man använde pakethanteraren synaptic, men det gick inte då heller, "följande kunde inte installeras pga av följande" och den det beror på "längst ner i beroende trädet" är libpango1.0-0, men den är redan installerad och det fungerade inte även om jag ominstallerade libpango1.0-0.